import re
regex = re.compile(r"^-?\d+$", flags=re.MULTILINE)
test_str = ("-1234\n"
"543\n"
"51.23\n"
"-512.345612\n"
"-5.1-2\n"
"-5.-2\n"
"5.1.2\n"
"51foo51\n"
"foo1\n"
"1foo\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")