// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^-?\d+$").unwrap();
let string = "-1234
543
51.23
-512.345612
-5.1-2
-5.-2
5.1.2
51foo51
foo1
1foo
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}