using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^\d.+-]|[-+](?!\.?\d)|[.](?!\d))+|[-+]?\d*[.]?\d+(?:[eE][-+]?\d+)?";
string input = @"We have the number 10 and 10.3, and i want to split both -124.45e-34 and +23.45 and -.86. -345+34.566-44354";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}