const regex = /(?:[^\d.+-]|[-+](?!\.?\d)|[.](?!\d))+|[-+]?\d*[.]?\d+(?:[eE][-+]?\d+)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[^\\d.+-]|[-+](?!\\.?\\d)|[.](?!\\d))+|[-+]?\\d*[.]?\\d+(?:[eE][-+]?\\d+)?', 'g')
const str = `We have the number 10 and 10.3, and i want to split both -124.45e-34 and +23.45 and -.86. -345+34.566-44354`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}