use strict;
my $str = 'We have the number 10 and 10.3, and i want to split both -124.45e-34 and +23.45 and -.86. -345+34.566-44354';
my $regex = qr/(?:[^\d.+-]|[-+](?!\.?\d)|[.](?!\d))+|[-+]?\d*[.]?\d+(?:[eE][-+]?\d+)?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}