import Foundation
let pattern = #"(?:[^\d.+-]|[-+](?!\.?\d)|[.](?!\d))+|[-+]?\d*[.]?\d+(?:[eE][-+]?\d+)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"We have the number 10 and 10.3, and i want to split both -124.45e-34 and +23.45 and -.86. -345+34.566-44354"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)