$re = '/(?:[^\d.+-]|[-+](?!\.?\d)|[.](?!\d))+|[-+]?\d*[.]?\d+(?:[eE][-+]?\d+)?/';
$str = 'We have the number 10 and 10.3, and i want to split both -124.45e-34 and +23.45 and -.86. -345+34.566-44354';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);