import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=>Expires at:<\\/label>\\n<div class=\\\"col-md-9\\\">\\n<p class=\\\"form-control-static\\\">\\n)([ \\w,]*?)\\s*<";
final String string = "<div class=\"col-md-6\">\n"
+ "<div class=\"form-group\">\n"
+ " <label class=\"control-label col-md-3\">Expires at:</label>\n"
+ "<div class=\"col-md-9\">\n"
+ "<p class=\"form-control-static\">\n"
+ "March 3rd, 2019 </p>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}