const regex = /(?<=>Expires at:<\/label>\n<div class=\"col-md-9\">\n<p class=\"form-control-static\">\n)([ \w,]*?)\s*</gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=>Expires at:<\\\/label>\\n<div class=\\"col-md-9\\">\\n<p class=\\"form-control-static\\">\\n)([ \\w,]*?)\\s*<', 'gm')
const str = `<div class="col-md-6">
<div class="form-group">
<label class="control-label col-md-3">Expires at:</label>
<div class="col-md-9">
<p class="form-control-static">
March 3rd, 2019 </p>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}