import re
regex = re.compile(r"(?<=>Expires at:<\/label>\n<div class=\"col-md-9\">\n<p class=\"form-control-static\">\n)([ \w,]*?)\s*<", flags=re.MULTILINE)
test_str = ("<div class=\"col-md-6\">\n"
"<div class=\"form-group\">\n"
" <label class=\"control-label col-md-3\">Expires at:</label>\n"
"<div class=\"col-md-9\">\n"
"<p class=\"form-control-static\">\n"
"March 3rd, 2019 </p>\n"
"</div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")