using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(.))(?!\1)";
string substitution = @"\n";
string input = @"hhhttrew
uuuuuuhhhaaajqqq
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}