$re = '/(?<=(.))(?!\1)/m';
$str = 'hhhttrew
uuuuuuhhhaaajqqq
';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;