re = /(?<=(.))(?!\1)/m
str = 'hhhttrew
uuuuuuhhhaaajqqq
'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result