const regex = new RegExp('(?<=(.))(?!\\1)', 'gm')
const str = `hhhttrew
uuuuuuhhhaaajqqq
`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);