use strict;
my $str = 'hhhttrew
uuuuuuhhhaaajqqq
';
my $regex = qr/(?<=(.))(?!\1)/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";