import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[:*\\n]";
final String string = "Languages: JAVA (2 years), Python (6 months), C (1 year), C++\n"
+ "Web Technologies: HTML, CSS3, PHP, JavaScript, JQuery, AJAX, Bootstrap, WordPress, JSP, Servlets, HTTP, XML, JSON\n"
+ "Databases: MySQL, PostgreSQL Amazon RDS, Dynamo DB, Google Cloud Datastore, SQL expert, NoSQL\n"
+ "Frameworks: Flask, SQL-Alchemy, Hive, JPA, Hibernate, Weka, NumPy, Pandas\n"
+ "Tools/Technology: Eclipse, PyCharm, Docker, AWS, Terminal, Unix Scripting, Tomcat, Maven, GIT, SVN, Arduino, PIC\n";
final String subst = ",";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}