import Foundation
let pattern = #"[:*\n]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Languages: JAVA (2 years), Python (6 months), C (1 year), C++
Web Technologies: HTML, CSS3, PHP, JavaScript, JQuery, AJAX, Bootstrap, WordPress, JSP, Servlets, HTTP, XML, JSON
Databases: MySQL, PostgreSQL Amazon RDS, Dynamo DB, Google Cloud Datastore, SQL expert, NoSQL
Frameworks: Flask, SQL-Alchemy, Hive, JPA, Hibernate, Weka, NumPy, Pandas
Tools/Technology: Eclipse, PyCharm, Docker, AWS, Terminal, Unix Scripting, Tomcat, Maven, GIT, SVN, Arduino, PIC
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)