# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d+\.(?![^\r\n|]*\|)//gm;t' <<< "blah, 1. retain 3. dont alter..blah | blah 1. remove balh.. 19. altered
"