use strict;
my $str = 'blah, 1. retain 3. dont alter..blah | blah 1. remove balh.. 19. altered
';
my $regex = qr/\d+\.(?![^\r\n|]*\|)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";