import Foundation
let pattern = #"\d+\.(?![^\r\n|]*\|)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
blah, 1. retain 3. dont alter..blah | blah 1. remove balh.. 19. altered
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)