using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+\.(?![^\r\n|]*\|)";
string substitution = @"";
string input = @"blah, 1. retain 3. dont alter..blah | blah 1. remove balh.. 19. altered
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}