import re
regex = re.compile(r"\d+\.(?![^\r\n|]*\|)", flags=re.MULTILINE)
test_str = ("blah, 1. retain 3. dont alter..blah | blah 1. remove balh.. 19. altered\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)