#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(I \[[[:digit:]]+\/\w+\/[[:digit:]]+(\:[[:digit:]]+)+ \+[[:digit:]]+\])(.*)(\r?\n(I \[[[:digit:]]+\/\w+\/[[:digit:]]+(\:[[:digit:]]+)+ \+[[:digit:]]+\])\3)+$"
Local $sString = "I [06/Jul/2020:21:30:35 +0700] Expiring subscriptions..." & @CRLF & _
"I [06/Jul/2020:21:30:36 +0700] Expiring subscriptions..." & @CRLF & _
"I [06/Jul/2020:21:30:37 +0700] Expiring subscriptions..." & @CRLF & _
"I [06/Jul/2020:21:30:38 +0700] Expiring subscriptions..." & @CRLF & _
"I [06/Jul/2020:21:30:39 +0700] Expiring subscriptions..." & @CRLF & _
"I [06/Jul/2020:21:30:40 +0700] Expiring subscriptions..." & @CRLF & _
"Expiring subscriptions" & @CRLF & _
"Expiring subscriptions" & @CRLF & _
"Expiring subscriptions" & @CRLF & _
"Expiring subscriptions" & @CRLF & _
"tr tr" & @CRLF & _
"tr tr" & @CRLF & _
"tr" & @CRLF & _
"I [06/Jul/2020:21:30:38 +0700] Expiring subscriptions..." & @CRLF & _
"I [06/Jul/2020:21:30:39 +0700] Expiring subscriptions..." & @CRLF & _
"I [06/Jul/2020:21:30:40 +0700] Expiring subscriptions..." & @CRLF & _
"tr" & @CRLF & _
"tr" & @CRLF & _
"tr"
Local $sSubst = "\1\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)