const regex = /^(I \[[[:digit:]]+\/\w+\/[[:digit:]]+(\:[[:digit:]]+)+ \+[[:digit:]]+\])(.*)(\r?\n(I \[[[:digit:]]+\/\w+\/[[:digit:]]+(\:[[:digit:]]+)+ \+[[:digit:]]+\])\3)+$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(I \\[[[:digit:]]+\\\/\\w+\\\/[[:digit:]]+(\\:[[:digit:]]+)+ \\+[[:digit:]]+\\])(.*)(\\r?\\n(I \\[[[:digit:]]+\\\/\\w+\\\/[[:digit:]]+(\\:[[:digit:]]+)+ \\+[[:digit:]]+\\])\\3)+$', 'mg')
const str = `I [06/Jul/2020:21:30:35 +0700] Expiring subscriptions...
I [06/Jul/2020:21:30:36 +0700] Expiring subscriptions...
I [06/Jul/2020:21:30:37 +0700] Expiring subscriptions...
I [06/Jul/2020:21:30:38 +0700] Expiring subscriptions...
I [06/Jul/2020:21:30:39 +0700] Expiring subscriptions...
I [06/Jul/2020:21:30:40 +0700] Expiring subscriptions...
Expiring subscriptions
Expiring subscriptions
Expiring subscriptions
Expiring subscriptions
tr tr
tr tr
tr
I [06/Jul/2020:21:30:38 +0700] Expiring subscriptions...
I [06/Jul/2020:21:30:39 +0700] Expiring subscriptions...
I [06/Jul/2020:21:30:40 +0700] Expiring subscriptions...
tr
tr
tr`;
const subst = `\1\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);