# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(I \[[[:digit:]]+\/\w+\/[[:digit:]]+(\:[[:digit:]]+)+ \+[[:digit:]]+\])(.*)(\r?\n(I \[[[:digit:]]+\/\w+\/[[:digit:]]+(\:[[:digit:]]+)+ \+[[:digit:]]+\])\3)+$"
test_str = ("I [06/Jul/2020:21:30:35 +0700] Expiring subscriptions...\n"
"I [06/Jul/2020:21:30:36 +0700] Expiring subscriptions...\n"
"I [06/Jul/2020:21:30:37 +0700] Expiring subscriptions...\n"
"I [06/Jul/2020:21:30:38 +0700] Expiring subscriptions...\n"
"I [06/Jul/2020:21:30:39 +0700] Expiring subscriptions...\n"
"I [06/Jul/2020:21:30:40 +0700] Expiring subscriptions...\n"
"Expiring subscriptions\n"
"Expiring subscriptions\n"
"Expiring subscriptions\n"
"Expiring subscriptions\n"
"tr tr\n"
"tr tr\n"
"tr\n"
"I [06/Jul/2020:21:30:38 +0700] Expiring subscriptions...\n"
"I [06/Jul/2020:21:30:39 +0700] Expiring subscriptions...\n"
"I [06/Jul/2020:21:30:40 +0700] Expiring subscriptions...\n"
"tr\n"
"tr\n"
"tr")
subst = "\\1\\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.