using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^98]";
string input = @"989127256533
9820207
20157
982188665998
4476587
989121465468
989194587989
98110
98119
989335465987
989206546545
989216548787";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}