$re = '/[^98]/m';
$str = '989127256533
9820207
20157
982188665998
4476587
989121465468
989194587989
98110
98119
989335465987
989206546545
989216548787';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);