const regex = /[^98]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^98]', 'gm')
const str = `989127256533
9820207
20157
982188665998
4476587
989121465468
989194587989
98110
98119
989335465987
989206546545
989216548787`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}