#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^extension:[a-z0-9_.-]+:[a-z0-9_.-]+$"
Local $sString = "extension:my:ext" & @CRLF & _
"extension:dns.resolve:extension" & @CRLF & _
"ext:wrong-extension" & @CRLF & _
"extension:Capital:Bad" & @CRLF & _
"extension:long-name-with-dashes:then.name.with.periods"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")