import re
regex = re.compile(r"^extension:[a-z0-9_.-]+:[a-z0-9_.-]+$", flags=re.MULTILINE)
test_str = ("extension:my:ext\n"
"extension:dns.resolve:extension\n"
"ext:wrong-extension\n"
"extension:Capital:Bad\n"
"extension:long-name-with-dashes:then.name.with.periods")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")