using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^extension:[a-z0-9_.-]+:[a-z0-9_.-]+$";
string input = @"extension:my:ext
extension:dns.resolve:extension
ext:wrong-extension
extension:Capital:Bad
extension:long-name-with-dashes:then.name.with.periods";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}