// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^extension:[a-z0-9_.-]+:[a-z0-9_.-]+$").unwrap();
let string = "extension:my:ext
extension:dns.resolve:extension
ext:wrong-extension
extension:Capital:Bad
extension:long-name-with-dashes:then.name.with.periods";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}