$re = '/^extension:[a-z0-9_.-]+:[a-z0-9_.-]+$/m';
$str = 'extension:my:ext
extension:dns.resolve:extension
ext:wrong-extension
extension:Capital:Bad
extension:long-name-with-dashes:then.name.with.periods';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);