#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^# ([A-Za-z0-9]+)|(?!^)\G)\n+([A-Za-z\.-\[\]\=\s\+]+)"
Local $sString = "# example" & @CRLF & _
"[Peer]" & @CRLF & _
"PublicKey = 123445" & @CRLF & _
"AllowedIPs = 127.0.0.1" & @CRLF & _
"" & @CRLF & _
"# example2" & @CRLF & _
"[Peer]" & @CRLF & _
"PublicKey = 123445" & @CRLF & _
"AllowedIPs = 127.0.0.1" & @CRLF & _
" " & @CRLF & _
"# example3" & @CRLF & _
"[Peer]" & @CRLF & _
"PublicKey = 123445" & @CRLF & _
"AllowedIPs = 127.0.0.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")