import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^# ([A-Za-z0-9]+)|(?!^)\\G)\\n+([A-Za-z\\.-\\[\\]\\=\\s\\+]+)";
final String string = "# example\n"
+ "[Peer]\n"
+ "PublicKey = 123445\n"
+ "AllowedIPs = 127.0.0.1\n\n"
+ "# example2\n"
+ "[Peer]\n"
+ "PublicKey = 123445\n"
+ "AllowedIPs = 127.0.0.1\n"
+ " \n"
+ "# example3\n"
+ "[Peer]\n"
+ "PublicKey = 123445\n"
+ "AllowedIPs = 127.0.0.1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}