use strict;
my $str = '# example
[Peer]
PublicKey = 123445
AllowedIPs = 127.0.0.1
# example2
[Peer]
PublicKey = 123445
AllowedIPs = 127.0.0.1
# example3
[Peer]
PublicKey = 123445
AllowedIPs = 127.0.0.1';
my $regex = qr/(?:^# ([A-Za-z0-9]+)|(?!^)\G)\n+([A-Za-z\.-\[\]\=\s\+]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}