$re = '/(?:^# ([A-Za-z0-9]+)|(?!^)\G)\n+([A-Za-z\.-\[\]\=\s\+]+)/m';
$str = '# example
[Peer]
PublicKey = 123445
AllowedIPs = 127.0.0.1
# example2
[Peer]
PublicKey = 123445
AllowedIPs = 127.0.0.1
# example3
[Peer]
PublicKey = 123445
AllowedIPs = 127.0.0.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);