import re
regex = re.compile(r"(?:^# ([A-Za-z0-9]+)|(?!^)\G)\n+([A-Za-z\.-\[\]\=\s\+]+)", flags=re.MULTILINE)
test_str = ("# example\n"
"[Peer]\n"
"PublicKey = 123445\n"
"AllowedIPs = 127.0.0.1\n\n"
"# example2\n"
"[Peer]\n"
"PublicKey = 123445\n"
"AllowedIPs = 127.0.0.1\n"
" \n"
"# example3\n"
"[Peer]\n"
"PublicKey = 123445\n"
"AllowedIPs = 127.0.0.1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")