$re = '/^[ \t]*((none|dotted|dashed|solid|double|groove|ridge|(?:in|out)set|hidden|inherit|initial|revert|unset){1}([ \t]+(none|dotted|dashed|solid|double|groove|ridge|(?:in|out)set|hidden|inherit|initial|revert|unset)){0,3})[\t ]*$/m';
$str = '
none
dotted
dashed
dotted dotted
dashed dashed dashed
solid solid solid solid
inset outset
# Errors - must not match
nonee
dotte2d
dashed-
dotted -dotted
dasheddashed dashed
solid fake solid solid';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);