import re
regex = re.compile(r"^[ \t]*((none|dotted|dashed|solid|double|groove|ridge|(?:in|out)set|hidden|inherit|initial|revert|unset){1}([ \t]+(none|dotted|dashed|solid|double|groove|ridge|(?:in|out)set|hidden|inherit|initial|revert|unset)){0,3})[\t ]*$", flags=re.MULTILINE)
test_str = (" \n"
" none\n"
"dotted \n"
" dashed \n"
" dotted dotted \n"
"dashed dashed dashed\n"
" solid solid solid solid\n"
" inset outset\n\n"
"# Errors - must not match\n"
"nonee\n"
"dotte2d\n"
"dashed-\n"
"dotted -dotted\n"
"dasheddashed dashed\n"
"solid fake solid solid")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")