package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(http|https)\:\/\/[a-zA-Z0-9\-\.]+(\.[a-zA-Z]{2,3})?(\/[A-Za-z0-9-._~!$&()*+,;=:]*)*`)
var str = `http://www.something.com and https://www.something.com</p> are working. Also http://www.something.com/some/thing/index.html works.
www.something.com not and http://something.com. also gives a problem. Also https://something.com/something/else/test?something=true.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}