re = /(http|https)\:\/\/[a-zA-Z0-9\-\.]+(\.[a-zA-Z]{2,3})?(\/[A-Za-z0-9-._~!$&()*+,;=:]*)*/m
str = 'http://www.something.com and https://www.something.com</p> are working. Also http://www.something.com/some/thing/index.html works.
www.something.com not and http://something.com. also gives a problem. Also https://something.com/something/else/test?something=true.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end