$re = '/(http|https)\:\/\/[a-zA-Z0-9\-\.]+(\.[a-zA-Z]{2,3})?(\/[A-Za-z0-9-._~!$&()*+,;=:]*)*/m';
$str = 'http://www.something.com and https://www.something.com</p> are working. Also http://www.something.com/some/thing/index.html works.
www.something.com not and http://something.com. also gives a problem. Also https://something.com/something/else/test?something=true.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);