// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(http|https)\:\/\/[a-zA-Z0-9\-\.]+(\.[a-zA-Z]{2,3})?(\/[A-Za-z0-9-._~!$&()*+,;=:]*)*").unwrap();
let string = "http://www.something.com and https://www.something.com</p> are working. Also http://www.something.com/some/thing/index.html works.
www.something.com not and http://something.com. also gives a problem. Also https://something.com/something/else/test?something=true.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}