#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<![\d/])(?:0[1-9]|1[0-2])/\d{4}(?![\d/])"
Local $sString = "06/2000" & @CRLF & _
"abc06/2000def" & @CRLF & _
"abc 06/2000 def" & @CRLF & _
"02/06/2000" & @CRLF & _
"02-06/2000" & @CRLF & _
"206/2000" & @CRLF & _
"13/2000" & @CRLF & _
"12/200" & @CRLF & _
"00/2000" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")