const regex = new RegExp('(?<![\\d/])(?:0[1-9]|1[0-2])/\\d{4}(?![\\d/])', 'gm')
const str = `06/2000
abc06/2000def
abc 06/2000 def
02/06/2000
02-06/2000
206/2000
13/2000
12/200
00/2000
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}