$re = '/(?<![\d/])(?:0[1-9]|1[0-2])/\d{4}(?![\d/])/m';
$str = '06/2000
abc06/2000def
abc 06/2000 def
02/06/2000
02-06/2000
206/2000
13/2000
12/200
00/2000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);