using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![\d/])(?:0[1-9]|1[0-2])/\d{4}(?![\d/])";
string input = @"06/2000
abc06/2000def
abc 06/2000 def
02/06/2000
02-06/2000
206/2000
13/2000
12/200
00/2000
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}