use strict;
my $str = '06/2000
abc06/2000def
abc 06/2000 def
02/06/2000
02-06/2000
206/2000
13/2000
12/200
00/2000
';
my $regex = qr/(?<![\d/])(?:0[1-9]|1[0-2])/\d{4}(?![\d/])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}