#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<prefixNr>.*)-(?<type>FE)-(?<suffixNr>.*)\.(?<ext>xml)$"
Local $sString = "003101172267-FE-00100001010001679522.xml" & @CRLF & _
"003101172267-MH-00100001010001679522.xml" & @CRLF & _
"003101172267-FE-00100001010001679522.PDF" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")